SCRAPY INSTALL IN LINUX MINT

Scrapy is a tool used for web – crawling

STEP 1:

Check python version in your machine

python — version

If python is not installed, install it using

sudo apt-get install python

STEP 2: ( Install Dependencies )

Scrapy depends on two pacakages “python-setuptools” and “pythonX.X.X – dev “

NOTE: X.X.X – indicates the version Example: 2.7.3

sudo apt-get install python-setuptools python2.7.3-dev

STEP 3:

Install Scrapy using easy_install” or  “python-pip”

To install using easy_install

easy_install scrapy

To install using python-pip

pip install scrapy

STEP 4:

To check whether it is installed correctly, enter scrapy in command line.

On successful installation you will get

Selection_002

Advertisements

DPKG Error : Sub-process /usr/bin/dpkg returned an error code (1)

While installing some software using linux terminal, we may encounter error like this

Sub-process /usr/bin/dpkg returned an error code (1)

I got this error while installing a library file “libpam0g:i386”.

Dpkg - Error

Just see the 4th line of this error.

dpkg: error processing /var/cache/apt/archives/libpam0g_1.1.3-7ubuntu3_i386.deb (–unpack):

The error can be rectified by using the command

sudo dpkg -i –force-overwrite /var/cache/apt/archives/libpam0g_1.1.3-7ubuntu3_i386.deb